package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([ABGDHVZChTIKLMNSOPTzQRShTh\s]{1,}\s[^.]*)`)
var str = `9 (Prime)
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}