using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([ABGDHVZChTIKLMNSOPTzQRShTh\s]{1,}\s[^.]*)";
string input = @"9 (Prime)
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}