import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:http(?:s?)://)?(?:[\\w]+\\.)+[a-zA-Z]+(?::\\d{1,5})?";
final String string = "hi 127.0.0.1\n"
+ "a20.20.20.21\n"
+ "s210.s2121.212.\n"
+ "3210.232.\n"
+ "200.200.500.23\n"
+ "200.200.200\n"
+ "www.google.com:2020\n"
+ "look at http://www.google.com:8080, please\n"
+ "google.com\n"
+ "http://www.google.com\n"
+ "https://google.com\n"
+ "https://www.google.com\n"
+ "https://www.google.com:12345\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}