#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:http(?:s?)://)?(?:[\w]+\.)+[a-zA-Z]+(?::\d{1,5})?"
Local $sString = "hi 127.0.0.1" & @CRLF & _
"a20.20.20.21" & @CRLF & _
"s210.s2121.212." & @CRLF & _
"3210.232." & @CRLF & _
"200.200.500.23" & @CRLF & _
"200.200.200" & @CRLF & _
"www.google.com:2020" & @CRLF & _
"look at http://www.google.com:8080, please" & @CRLF & _
"google.com" & @CRLF & _
"http://www.google.com" & @CRLF & _
"https://google.com" & @CRLF & _
"https://www.google.com" & @CRLF & _
"https://www.google.com:12345" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")