// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^\s]\s*END").unwrap();
let string = " -- if this is a checkbox,
IF (@widget = 'Checkbox')BEGIN
EXECUTE [dbo].[home_save_slip_checkbox] @school_fk = @school_fk, @slip_fk = @res_output, @definition_field_fk = @definition_field_fk, @notes = '', @points = @points, @student_fk = @student_fk, @academic_year = @academic_year, @occurred_date = @occurred_date END
-- if this is an exclusion
IF (@widget = 'Exclusion')BEGIN
EXECUTE [dbo].[home_save_slip_exclusion] @slip_fk = @res_output, @school_fk = @school_fk, @student_fk = @student_fk , @ocean_user_fk = @ocean_user_fk, @definition_field_fk = @definition_field_fk, @points = @points, @exclusion_type = 'Internal', @exclusion_duration = 3, @start_date = @occurred_date , @notes = '', @d_of_e_reason_code = 'BU' , @reason = '', @academic_year = @academic_year, @category = 'FIXD', @occurred_date = @occurred_date , @definition_location_fk = @definition_location_fk END
-- if this is a detention
IF (@widget = 'Detention')BEGIN
EXECUTE [home_save_slip_detention] @slip_fk = @res_output, @school_fk = @school_fk, @student_fk = @student_fk , @definition_field_fk = @definition_field_fk, @detention_date = @occurred_date , @detention_location_fk = @definition_location_fk, @detention_duration = 30, @points = @points, @definition_slip_fk = @definition_slip_fk, @definition_subject_fk = @definition_subject_fk, @definition_class_fk = -1, @academic_year = @academic_year, @occurred_date = @occurred_date , @detention_reason = '', @detention_work_to_be_completed = '' END
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}