# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\s(?:from|join)\s*(\[?[\S]+)\]?(?:\s?)(?:(?:as)?\s?)(?!(join|where|from|left|right|outer|inner|on))(\w*)"
test_str = ("\n"
"SELECT a.ACCTNO, \n"
"case [DCCDRID] when 'N/A' then 'N/A' else dbo.GETDocNames(DCCDRID) end AS [Specific Documents Needed],\n"
"a.CUSTRF, \n"
"b.[RLEXT#], \n"
"a.APPLCT, \n"
"a.SADDR1, \n"
"a.SADDR2, \n"
"a.SCITY, \n"
"a.SSTATE, \n"
"a.SZIP, \n"
"a.CFOReqstType\n"
"FROM (\n"
"SELECT a.ACCTNO, \n"
"a.CUSTRF, \n"
"a.MINNBR, \n"
"a.[GSE_NO] AS [FNMA#], \n"
"a.GSEPN AS [FNMA MBS Pool Number], \n"
"a.GSESN AS [FNMA Master Servicer Number], \n"
"a.APPLCT, \n"
"a.SADDR1, \n"
"a.SADDR2, \n"
"a.SCITY, \n"
"a.SSTATE, \n"
"a.SZIP, \n"
"a.RefreshRunDT AS [Request Date], \n"
"a.TRANDT AS [Paid Date], \n"
"a.OrgLnBal AS [Orig Loan Amt], \n"
"b.CustodianName, \n"
"a.FileDestName, \n"
"a.CSTSEQ, \n"
"a.CSTFileDest, \n"
"a.CSTRelCode, \n"
"a.CFOOrderReasonCode, \n"
"a.CFOReqstType, \n"
"a.DCCDRID\n"
"FROM [PRODLIB].[dbo].[DOCUS_SYS_REFRESH_CFO_DAILY] a\n"
"INNER JOIN tbl_DC_CLU_CUSTD b \n"
" ON a.CSTSEQ = b.CSTSEQ\n"
"WHERE a.CSTSEQ In (23,34,35,39,53,54)\n"
") a \n"
"INNER JOIN DOCUS_PRODLIB_CLPREFAL b\n"
" ON a.ACCTNO = b.[RLNEW#]\n"
"WHERE a.CSTSEQ = 23")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.