import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s(?:from|join)\\s*(\\[?[\\S]+)\\]?(?:\\s?)(?:(?:as)?\\s?)(?!(join|where|from|left|right|outer|inner|on))(\\w*)";
final String string = "\n"
+ "SELECT a.ACCTNO, \n"
+ "case [DCCDRID] when 'N/A' then 'N/A' else dbo.GETDocNames(DCCDRID) end AS [Specific Documents Needed],\n"
+ "a.CUSTRF, \n"
+ "b.[RLEXT#], \n"
+ "a.APPLCT, \n"
+ "a.SADDR1, \n"
+ "a.SADDR2, \n"
+ "a.SCITY, \n"
+ "a.SSTATE, \n"
+ "a.SZIP, \n"
+ "a.CFOReqstType\n"
+ "FROM (\n"
+ "SELECT a.ACCTNO, \n"
+ "a.CUSTRF, \n"
+ "a.MINNBR, \n"
+ "a.[GSE_NO] AS [FNMA#], \n"
+ "a.GSEPN AS [FNMA MBS Pool Number], \n"
+ "a.GSESN AS [FNMA Master Servicer Number], \n"
+ "a.APPLCT, \n"
+ "a.SADDR1, \n"
+ "a.SADDR2, \n"
+ "a.SCITY, \n"
+ "a.SSTATE, \n"
+ "a.SZIP, \n"
+ "a.RefreshRunDT AS [Request Date], \n"
+ "a.TRANDT AS [Paid Date], \n"
+ "a.OrgLnBal AS [Orig Loan Amt], \n"
+ "b.CustodianName, \n"
+ "a.FileDestName, \n"
+ "a.CSTSEQ, \n"
+ "a.CSTFileDest, \n"
+ "a.CSTRelCode, \n"
+ "a.CFOOrderReasonCode, \n"
+ "a.CFOReqstType, \n"
+ "a.DCCDRID\n"
+ "FROM [PRODLIB].[dbo].[DOCUS_SYS_REFRESH_CFO_DAILY] a\n"
+ "INNER JOIN tbl_DC_CLU_CUSTD b \n"
+ " ON a.CSTSEQ = b.CSTSEQ\n"
+ "WHERE a.CSTSEQ In (23,34,35,39,53,54)\n"
+ ") a \n"
+ "INNER JOIN DOCUS_PRODLIB_CLPREFAL b\n"
+ " ON a.ACCTNO = b.[RLNEW#]\n"
+ "WHERE a.CSTSEQ = 23";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}