$re = '/^(.*?([^\(=\s!<>]+?)\s*?=[^=<>].*;)(.*)$/';
$str = 'int ab= a+1; if(aaaa = 1) // b+1; //hogera
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);