using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?([^\(=\s!<>]+?)\s*?=[^=<>].*;)(.*)$";
string input = @"int ab= a+1; if(aaaa = 1) // b+1; //hogera
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}