re = /^\((?P<a>[+-]?\d+)?(?P<sign_x>[+-])?(?P<x>[a-zA-Z])(?P<b>[+-]\d+)\)(?:\^(?P<n>\d*))?$/m
str = '(-1x+1)^3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end