using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\((?P<a>[+-]?\d+)?(?P<sign_x>[+-])?(?P<x>[a-zA-Z])(?P<b>[+-]\d+)\)(?:\^(?P<n>\d*))?$";
string input = @"(-1x+1)^3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}