$re = '/^(0[1-9]|1[0-2])\/?([0-9]{2})$/';
$str = '12/90';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);