package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([1-9]|[1-9][0-9]|[1-9][0-9][0-9])$`)
var str = `<--! select 1..999 sequences -->
0
1
9
00
09
10
99
000
001
002
004
010
011
021
100
101
110
115
120
125
127
135
139
141
201
222
230
245
247
250
254 sgnlfsf
2340
345
255
853
999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}