#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([1-9]|[1-9][0-9]|[1-9][0-9][0-9])$"
Local $sString = "<--! select 1..999 sequences -->" & @CRLF & _
"0" & @CRLF & _
"1" & @CRLF & _
"9" & @CRLF & _
"00" & @CRLF & _
"09" & @CRLF & _
"10" & @CRLF & _
"99" & @CRLF & _
"000" & @CRLF & _
"001" & @CRLF & _
"002" & @CRLF & _
"004" & @CRLF & _
"010" & @CRLF & _
"011" & @CRLF & _
"021" & @CRLF & _
"100" & @CRLF & _
"101" & @CRLF & _
"110" & @CRLF & _
"115" & @CRLF & _
"120" & @CRLF & _
"125" & @CRLF & _
"127" & @CRLF & _
"135" & @CRLF & _
"139" & @CRLF & _
"141" & @CRLF & _
"201" & @CRLF & _
"222" & @CRLF & _
"230" & @CRLF & _
"245" & @CRLF & _
"247" & @CRLF & _
"250" & @CRLF & _
"254 sgnlfsf" & @CRLF & _
"2340" & @CRLF & _
"345" & @CRLF & _
"255" & @CRLF & _
"853" & @CRLF & _
"999"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")