import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Z a-z 0-9 * - + = _ . # ~ ! ]{1,}";
final String string = "^@*#(#))#__##\n"
+ "hellow world \n"
+ "dfafa\n"
+ "fdadfa\n"
+ "afafa\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}