#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[A-Z a-z 0-9 * - + = _ . # ~ ! ]{1,}"
Local $sString = "^@*#(#))#__##" & @CRLF & _
"hellow world " & @CRLF & _
"dfafa" & @CRLF & _
"fdadfa" & @CRLF & _
"afafa" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")