using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*NSRL(.*:.\D*\d*).*µg\/day)";
string input = @"FOR INHALATION AND ORAL ROUTES : NSRL - Oral: 6.4 µg/day and MADL - Oral : 24 µg/day NSRL - Inhalation: 13 µg/day and MADL - Inhalation: 49 µg/day Only if concentration of this substance is higher than the safe harbor level (ingredient or impurity) : This product can expose you to chemicals including [name of one or more chemicals], which is [are] known to the State of California to cause [cancer] and [birth defects or other reproductive harm]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}