$re = '/(\D*)_(\d{2})-(\d{4})/';
$str = 'Statement_06-2014';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);