package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\D*)_(\d{2})-(\d{4})`)
var str = `Statement_06-2014`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}