$re = '/Vous\savez\srecu\sun\stransfert\sde\s(?P<amount>\d+)FCFA\sde\s(?P<sender_name>.*)\s\((?P<sender_phone>\d+)\)\sle\s(?P<when>.*?)\..*ID.*transaction\s.*?(?P<transaction_id>\d+)\.*/m';
$str = 'Vous avez recu un transfert de 12300FCFA de Comlan Louis Barthelemy Djihoulande (22997870329) le 2023-06-25 11:26:57. Reference: d. Nouveau solde: 20120 FCFA. ID de la transaction : 5041378775..';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);