const regex = new RegExp('Vous\\savez\\srecu\\sun\\stransfert\\sde\\s(?P<amount>\\d+)FCFA\\sde\\s(?P<sender_name>.*)\\s\\((?P<sender_phone>\\d+)\\)\\sle\\s(?P<when>.*?)\\..*ID.*transaction\\s.*?(?P<transaction_id>\\d+)\\.*', 'gm')
const str = `Vous avez recu un transfert de 12300FCFA de Comlan Louis Barthelemy Djihoulande (22997870329) le 2023-06-25 11:26:57. Reference: d. Nouveau solde: 20120 FCFA. ID de la transaction : 5041378775..`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}