$re = '/(?:\d+\s+)(\w+)(?:\s+)(\w+)/m';
$str = ' Id Name State
----------------------------------------------------
14 vm2 running
19 vm7 running
22 vm10 running
27 vm11 running
36 vm9 running
38 vm12 running
43 vm6 running
46 vm1 running
49 vm4 running
63 vm5 running
65 vm8 running
67 vm3 running
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);