import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\d+\\s+)(\\w+)(?:\\s+)(\\w+)";
final String string = " Id Name State\n"
+ "----------------------------------------------------\n"
+ " 14 vm2 running\n"
+ " 19 vm7 running\n"
+ " 22 vm10 running\n"
+ " 27 vm11 running\n"
+ " 36 vm9 running\n"
+ " 38 vm12 running\n"
+ " 43 vm6 running\n"
+ " 46 vm1 running\n"
+ " 49 vm4 running\n"
+ " 63 vm5 running\n"
+ " 65 vm8 running\n"
+ " 67 vm3 running\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}