$re = '`^\s{1,}|\s{1,}$`';
$str = ' rafael angel ramirez ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);