package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\s{1,}|\s{1,}$`)
var str = ` rafael angel ramirez `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}