# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b\w+[-._]?\w+@\w+\.[a-z]{2,3}+/$1/g;t' <<< "el texto que se escribe en plan rutinario asi mientras se hacen otras cosas con el ojo izquierdo izquierdo sobre todo si se copia y y pega bueno eso es una fuente inagotable de errores y errores y errores tantos que hay quien se dedica a encontrar algunos de ellos ellos con magnificas y sofisticadas aplicaciones como esto del regex que suena a comprimidos con sabor a menta para aliviar la acidez de estomago despues de de comidas abusivas feld-grau@hotmail.com arjamcl@yahoo.com "