# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<span.*>(.*?)<\/span>"
test_str = ("<!--WYSIWYG content - do not remove this comment, and never use this identical text in your topics-->\n"
"<p>-- <span class=\"WYSIWYG_LINK\">Main.SeanOReilly</span> - 2017-08-30</p>\n"
"<h1 class=\"TML\">Technology used</h1>\n"
"<p><span class=\"WYSIWYG_LINK\">[[http://www.oracle.com/technetwork/developer-tools/rest-data-services/overview/index.html][ORDS (Oracle REST data services)]]</span></p>\n"
"<h1 class=\"TML\"></h1>\n"
"<h1 class=\"TML\">REST concepts</h1>\n"
"<table border=\"1\" cellspacing=\"1\" cellpadding=\"0\">\n"
"<tbody>\n"
"<tr>\n"
"<td>GET</td>\n"
"<td class=\"align-left\" style=\"text-align: left\">select</td>\n"
"</tr>\n"
"<tr>\n"
"<td>POST</td>\n"
"<td class=\"align-left\" style=\"text-align: left\">insert</td>\n"
"</tr>\n"
"<tr>\n"
"<td>PUT</td>\n"
"<td class=\"align-left\" style=\"text-align: left\">update</td>\n"
"</tr>\n"
"<tr>\n"
"<td>DELETE</td>\n"
"<td class=\"align-left\" style=\"text-align: left\">delete</td>\n"
"</tr>\n"
"</tbody>\n"
"</table>\n"
"<h1 class=\"TML\"></h1>\n"
"<h1 class=\"TML\">Settings</h1>\n"
"<p><img title=\"ORDS_ords_admin.JPG\" src=\"http://itwiki.core.kmtltd.net.au/pub/Main/SupplyChainIntl/RESTDataAPI/ORDS_ords_admin.JPG\" alt=\"ORDS_ords_admin.JPG\" width=\"356\" height=\"281\" /></p>\n"
"<p><img title=\"ORDS_ords_dev.JPG\" src=\"http://itwiki.core.kmtltd.net.au/pub/Main/SupplyChainIntl/RESTDataAPI/ORDS_ords_dev.JPG\" alt=\"ORDS_ords_dev.JPG\" width=\"356\" height=\"281\" /></p>\n"
"<p><span class=\"WYSIWYG_LINK\">[[http://www.oracle.com/technetwork/developer-tools/rest-data-services/learnmore/index.html]]</span></p>\n"
"<h1 class=\"TML\">Kmart Developer website</h1>\n"
"<p><span class=\"WYSIWYG_LINK\">[[https://developer.core.kmtltd.net.au/]]</span></p>\n"
"<h1 class=\"TML\">Data dictionary</h1>\n"
"<p><span class=\"WYSIWYG_LINK\">ProductNumber</span></p>\n"
"<p><span class=\"WYSIWYG_LINK\">UnitQuantity</span></p>\n"
"<h1 class=\"TML\">Development notes</h1>\n"
"<p>\\\\warthog\\grpdata\\Kmart IT Team\\4. Supply Chain & Finance Delivery\\1. GIF\\1. Apps & Systems\\5. Other\\Tasks\\170823 API</p>\n"
"<h1 class=\"TML\">Examples</h1>\n"
"<h2 class=\"TML\"><span class=\"WYSIWYG_LINK\">AutoREST</span></h2>\n"
"<p><span class=\"WYSIWYG_LINK\">http://kuttsi901:8080/ords/exuts/container/</span></p>\n"
"<h2 class=\"TML\">Configured REST</h2>\n"
"<p><span class=\"WYSIWYG_LINK\">http://kuttsi901:8080/ords/exuts//v1/container/MAEU8378519</span></p>")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.