# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(select\s.*from\s|delete\s+from\s|insert\s+into\s.*values\s|update\s.*set\s)"
test_str = ("Request osmcha analysis for changeset ids and update edits table with flags.\n\n"
" All cs ids are passed as a parameter to the api request (in case of a large\n"
" number of changesets,they will be split into multiple lists, i.e. this will\n"
" result in multiple requests).\n"
" The flags of each changeset are aggregated and uploaded into the db.\n\n"
" To see possible values of reasons look at osmcha_reasons.md.\n"
" :param settings:\n"
" :return:")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.