#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?msi)(select\s.*from\s|delete\s+from\s|insert\s+into\s.*values\s|update\s.*set\s)"
Local $sString = "Request osmcha analysis for changeset ids and update edits table with flags." & @CRLF & _
"" & @CRLF & _
" All cs ids are passed as a parameter to the api request (in case of a large" & @CRLF & _
" number of changesets,they will be split into multiple lists, i.e. this will" & @CRLF & _
" result in multiple requests)." & @CRLF & _
" The flags of each changeset are aggregated and uploaded into the db." & @CRLF & _
"" & @CRLF & _
" To see possible values of reasons look at osmcha_reasons.md." & @CRLF & _
" :param settings:" & @CRLF & _
" :return:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")