const regex = /^([a-zA-Z0-9]+)\.(jpg|png|gif|bmp|pdf)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-zA-Z0-9]+)\\.(jpg|png|gif|bmp|pdf)', '')
const str = `cXdyORNyNzA0NDEzMjA9NmMmJSIiNTM2FjUyeHd4fg.png`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}