using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-Z0-9]+)\.(jpg|png|gif|bmp|pdf)";
string input = @"cXdyORNyNzA0NDEzMjA9NmMmJSIiNTM2FjUyeHd4fg.png";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}