re = /^([A-E])([A-C])([0-2])(\d)([0-5])(\d)([B])(\d{6})([A-Z0-9]{2})(\d{3})$/
str = 'BA1541B0098362B043'
# Print the match result
str.match(re) do |match|
puts match.to_s
end