package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([A-E])([A-C])([0-2])(\d)([0-5])(\d)([B])(\d{6})([A-Z0-9]{2})(\d{3})$`)
var str = `BA1541B0098362B043`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}