re = /\{((\r?\n)*.+?(\r?\n)*)\}/m
str = 'Int function(char c) {
Int a = 0;
}
Int function(char c) {
Int a = 0;
Int a = 0;
}
Int function(char c) { Int a = 0;}
Int function(char c) {
Int function(char c) { Int a = 0; }
}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end