using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{((\r?\n)*.+?(\r?\n)*)\}";
string input = @"Int function(char c) {
Int a = 0;
}
Int function(char c) {
Int a = 0;
Int a = 0;
}
Int function(char c) { Int a = 0;}
Int function(char c) {
Int function(char c) { Int a = 0; }
}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}