import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?'MAJOR'0|(?:[1-9]\\d*))\\.(?'MINOR'0|(?:[1-9]\\d*))\\.(?'PATCH'0|(?:[1-9]\\d*))(?:-(?'prerelease'(?:0|(?:[1-9A-Za-z-][0-9A-Za-z-]*))(?:\\.(?:0|(?:[1-9A-Za-z-][0-9A-Za-z-]*)))*))?(?:\\+(?'build'(?:0|(?:[1-9A-Za-z-][0-9A-Za-z-]*))(?:\\.(?:0|(?:[1-9A-Za-z-][0-9A-Za-z-]*)))*))?$";
final String string = "1.0.0-alpha-a.b-c-somethinglong+build.1-aef.1-its-okay\n"
+ "1.0.0+0.build.1-rc.10000aaa-kk-0.1\n"
+ "1.0.0-rc.1+build.1\n"
+ "2.0.0-rc.1+build.123\n"
+ "0.0.4\n"
+ "1.2.3\n"
+ "10.20.30\n"
+ "1.2.3-beta\n"
+ "10.2.3-DEV-SNAPSHOT\n"
+ "1.2.3-SNAPSHOT-123\n"
+ "1.0.0\n"
+ "2.0.0\n"
+ "1.1.7\n"
+ "2.0.0+build.1848\n"
+ "2.0.1-alpha.1227\n"
+ "1.2.3----RC-SNAPSHOT.12.9.1--.12+788\n\n\n"
+ "01.1.1\n"
+ "1.2\n"
+ "1.2.3.DEV\n"
+ "1.2-SNAPSHOT\n"
+ "1.2.3----RC-SNAPSHOT.12.09.1--..12+788\n"
+ "1.2-RC-SNAPSHOT\n"
+ "-1.0.3-gamma+b7718\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}