#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?'MAJOR'0|(?:[1-9]\d*))\.(?'MINOR'0|(?:[1-9]\d*))\.(?'PATCH'0|(?:[1-9]\d*))(?:-(?'prerelease'(?:0|(?:[1-9A-Za-z-][0-9A-Za-z-]*))(?:\.(?:0|(?:[1-9A-Za-z-][0-9A-Za-z-]*)))*))?(?:\+(?'build'(?:0|(?:[1-9A-Za-z-][0-9A-Za-z-]*))(?:\.(?:0|(?:[1-9A-Za-z-][0-9A-Za-z-]*)))*))?$"
Local $sString = "1.0.0-alpha-a.b-c-somethinglong+build.1-aef.1-its-okay" & @CRLF & _
"1.0.0+0.build.1-rc.10000aaa-kk-0.1" & @CRLF & _
"1.0.0-rc.1+build.1" & @CRLF & _
"2.0.0-rc.1+build.123" & @CRLF & _
"0.0.4" & @CRLF & _
"1.2.3" & @CRLF & _
"10.20.30" & @CRLF & _
"1.2.3-beta" & @CRLF & _
"10.2.3-DEV-SNAPSHOT" & @CRLF & _
"1.2.3-SNAPSHOT-123" & @CRLF & _
"1.0.0" & @CRLF & _
"2.0.0" & @CRLF & _
"1.1.7" & @CRLF & _
"2.0.0+build.1848" & @CRLF & _
"2.0.1-alpha.1227" & @CRLF & _
"1.2.3----RC-SNAPSHOT.12.9.1--.12+788" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"01.1.1" & @CRLF & _
"1.2" & @CRLF & _
"1.2.3.DEV" & @CRLF & _
"1.2-SNAPSHOT" & @CRLF & _
"1.2.3----RC-SNAPSHOT.12.09.1--..12+788" & @CRLF & _
"1.2-RC-SNAPSHOT" & @CRLF & _
"-1.0.3-gamma+b7718" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")