import Foundation
let pattern = #"[[Video:(http)\:\/\/[a-zA-Z0-9\-\.]+\.[a-zA-Z]{2,3}(\/\S*)?4"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<p class="arttxt_tit">ARTBLOG YAZARIMIZ OLUN! ekavArtblog</p>
<p class="arttxt"><i>22.11.2011</i></p>
<p class="arttxt">
<p style="text-align: center;">
<br />
<img alt="" src="http://www.ekavart.tv/handlers/Image.ashx?id=984" style="width: 364px; height: 272px;" /><br />
<br />
<br />
Sanatla ilgili her türlü yazınısı bizle paylaşın, yayınlayalım.<br />
<br />
Yazılarınızı, iletişim bilgilerinizle beraber info@ekavart.tv adresine en az 5 görselle gönderebilirsiniz.</p>
[[Video:http://data.ekavart.tv/ekav/temp/mp4/2016/7/13/3061.mp4
</p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)