use strict;
my $str = ' <p class="arttxt_tit">ARTBLOG YAZARIMIZ OLUN! ekavArtblog</p>
<p class="arttxt"><i>22.11.2011</i></p>
<p class="arttxt">
<p style="text-align: center;">
<br />
<img alt="" src="http://www.ekavart.tv/handlers/Image.ashx?id=984" style="width: 364px; height: 272px;" /><br />
<br />
<br />
Sanatla ilgili her türlü yazınısı bizle paylaşın, yayınlayalım.<br />
<br />
Yazılarınızı, iletişim bilgilerinizle beraber info@ekavart.tv adresine en az 5 görselle gönderebilirsiniz.</p>
[[Video:http://data.ekavart.tv/ekav/temp/mp4/2016/7/13/3061.mp4
</p>
';
my $regex = qr/[[Video:(http)\:\/\/[a-zA-Z0-9\-\.]+\.[a-zA-Z]{2,3}(\/\S*)?4/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}