use strict;
my $str = '128.32.1.1';
my $regex = qr/(?<!\d)(\d)(?!\d)/p;
my $subst = '0$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";