using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\d)(\d)(?!\d)";
string substitution = @"0$1";
string input = @"128.32.1.1";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}