re = /([\w]+)\s?=\s?([-+\s]*?([0-9]*\.[0-9]+|[0-9]+))?([-+])*([Ss]in|[Rr]amp)\((?:FinalValue:|Amplitude:)([-+\s]*?([0-9]*\.[0-9]+|[0-9]+))([\w]*),(?:Frequency:|RampTime:)([0-9]*\.[0-9]+|[0-9]+)([\w]*)\)/
str = 'Rx_TrqMax_Rq = Ramp(FinalValue:100Nm,RampTime:10ms)
Rx_TrqMax_Rq =100+Ramp(FinalValue:100.50Nm,RampTime:10ms)
Rx_TrqMax_Rq = -100.50+Ramp(FinalValue:100Nm,RampTime:10ms)
Rx_TrqMax_Rq = -100.50-Ramp(FinalValue:100Nm,RampTime:10ms)
Rx_TrqMax_Rq = 100+Sin(Amplitude:100Nm,Frequency:10ms)
Rx_TrqMax_Rq = -100-Sin(Amplitude:100Nm,Frequency:10ms)
Rx_TrqMax_Rq = Sin(Amplitude:100Nm,Frequency:10ms)
Rx_TrqMax_Rq = 100+Sin(Amplitude:100Nm,Frequency:10ms)
Rx_TrqMax_Rq = 100.50+Sin(Amplitude:100Nm,Frequency:10.5s)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end