package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\w]+)\s?=\s?([-+\s]*?([0-9]*\.[0-9]+|[0-9]+))?([-+])*([Ss]in|[Rr]amp)\((?:FinalValue:|Amplitude:)([-+\s]*?([0-9]*\.[0-9]+|[0-9]+))([\w]*),(?:Frequency:|RampTime:)([0-9]*\.[0-9]+|[0-9]+)([\w]*)\)`)
var str = `Rx_TrqMax_Rq = Ramp(FinalValue:100Nm,RampTime:10ms)
Rx_TrqMax_Rq =100+Ramp(FinalValue:100.50Nm,RampTime:10ms)
Rx_TrqMax_Rq = -100.50+Ramp(FinalValue:100Nm,RampTime:10ms)
Rx_TrqMax_Rq = -100.50-Ramp(FinalValue:100Nm,RampTime:10ms)
Rx_TrqMax_Rq = 100+Sin(Amplitude:100Nm,Frequency:10ms)
Rx_TrqMax_Rq = -100-Sin(Amplitude:100Nm,Frequency:10ms)
Rx_TrqMax_Rq = Sin(Amplitude:100Nm,Frequency:10ms)
Rx_TrqMax_Rq = 100+Sin(Amplitude:100Nm,Frequency:10ms)
Rx_TrqMax_Rq = 100.50+Sin(Amplitude:100Nm,Frequency:10.5s)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}