// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(interface|uso|down)|(range|IPs|IP's)|(vlan|trunk|switch|subinterface)|(vrf|vpn|instancia|instância)|(policy|class|classe|política|politica|qos)|(rota|roteamento|routing|bgp|ospf)|(reatribuir|agendar|data|alinhada|conexões|conexoes|fisicas|físicas)").unwrap();
let string = "Reatribuir quando conexões físicas estiverem prontas
Ticket Rejeitado Conforme Email - 25/04/2017
NOK. Rejeitar WO. Plano não migra subinterfaces e não configura OSPF. - 02/05/2017
Ranges do plano 10.208.25.192/27 e 10.208.25.224/27 coincidindo com os IPs das interface Gi2/14 até 2/19 dos switches (Conexão com PTFNS01/02). Necessário verificar e, se for o caso, contemplar o clean-up destas interfaces no plano.
Rejeitar. A WO0317030653 (que foi rejeitada) é pré-requisito desta.
Atividade Rejeitada conforme Email - 08/05/2017 -
Atividade Rejeitada conforme email - 08/05/2017 Rejeitar.
Atividade Rejeitada Conforme Email - 08/05/2017 As vlans adicionadas no trunk não estão criadas nos switches.
Encaminhar WO quando houver data alinhada
Cancelada por OSS
Rede IP já alocada em sts.
Atividade Rejeitada - 22/05/2017 - verificamos que a WO não atende as solicitações feitas para engenharia. Acioli cobrara dos mesmos a correçao
Interface já estava migrada para instância DCN, sem necessidade de rota estática.
Devolver ticket quando houver entrega do circuito do \"lado 02\". Atividade executada parcialmente.
Falta config SWACITZ0101 e do RTEDITZ
RP/0/RSP0/CPU0:RTARRJO0101(config-bgp-nbr-af)#commit
Encaminhar ticket quando houver data alinhada para execução de atividade
Interface com tráfego de 90Mpbs
Favor, reatribuir ticket quando link tiver \"subido\".
Reencaminhar WO quando houver data alinhada para execução
Devolver WO quando houver data alinhada para atividade. Interfaces em uso.
Reatribuir ticket quando link estiver up.
Devolver WO quando houver data alinhada para atividade. Interfaces em uso.
retornar ticket quando houver alinhamento
Favor, reatribuir tioket quando houver data alinhada para migração.
Encaminhar WO quando houver data alinhada
favor prosseguir com a execução.
Quando houver data alinhada para realização dos passos 3 e 4 do plano, favor, reencaminhar WO.
Favor, reencaminhar WO quando houver data alinhada com BACKHAUL/FTTS
Todas as portas dos Switches estão bloqueadas mas configuradas para outros projetos. Como não tem o ¿default interface¿, não realizado.
Plano não contempla redundância de chassis ¿ enviado e-mail para esclarecimento da eng BBPIP
Portas em uso.
O next-hop de uma das rotas (ip route 10.208.150.64 255.255.255.252 10.208.192.39 tag 40001 name AFOZ03_IUCS_UP ) não é válida. O IP 10.208.192.39 faz parte da rede O&M SIAE de LDA02 . Além disso, as portas do switch 01 estão em uso
Encaminhar WO quando houver data alinhada / Circuito entregue
De acordo com o projeto VSS, a alocação de portas deve acompanhar o par VSS em questão, não sendo possível estender o perímetro L2, ou seja, a vlan 320 deveria estar exclusivamente no SWAVRJO0201 e a vlan 574 exclusivamente no SWAVRJO0202.
Senhores, favor, reencaminhar ticket perto de deta alianhada para integração/ migração de enodebs.
WO desconfigura interface com tráfego e com neighbor BGP UP. Favor rever configuração ou passar maiores informações";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}