#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(interface|uso|down)|(range|IPs|IP's)|(vlan|trunk|switch|subinterface)|(vrf|vpn|instancia|instância)|(policy|class|classe|política|politica|qos)|(rota|roteamento|routing|bgp|ospf)|(reatribuir|agendar|data|alinhada|conexões|conexoes|fisicas|físicas)"
Local $sString = "Reatribuir quando conexões físicas estiverem prontas" & @CRLF & _
"Ticket Rejeitado Conforme Email - 25/04/2017" & @CRLF & _
"NOK. Rejeitar WO. Plano não migra subinterfaces e não configura OSPF. - 02/05/2017" & @CRLF & _
"Ranges do plano 10.208.25.192/27 e 10.208.25.224/27 coincidindo com os IPs das interface Gi2/14 até 2/19 dos switches (Conexão com PTFNS01/02). Necessário verificar e, se for o caso, contemplar o clean-up destas interfaces no plano." & @CRLF & _
"Rejeitar. A WO0317030653 (que foi rejeitada) é pré-requisito desta." & @CRLF & _
"Atividade Rejeitada conforme Email - 08/05/2017 -" & @CRLF & _
"Atividade Rejeitada conforme email - 08/05/2017 Rejeitar." & @CRLF & _
"Atividade Rejeitada Conforme Email - 08/05/2017 As vlans adicionadas no trunk não estão criadas nos switches." & @CRLF & _
"Encaminhar WO quando houver data alinhada" & @CRLF & _
"Cancelada por OSS" & @CRLF & _
"Rede IP já alocada em sts." & @CRLF & _
"Atividade Rejeitada - 22/05/2017 - verificamos que a WO não atende as solicitações feitas para engenharia. Acioli cobrara dos mesmos a correçao" & @CRLF & _
"Interface já estava migrada para instância DCN, sem necessidade de rota estática." & @CRLF & _
"Devolver ticket quando houver entrega do circuito do "lado 02". Atividade executada parcialmente." & @CRLF & _
"Falta config SWACITZ0101 e do RTEDITZ" & @CRLF & _
"RP/0/RSP0/CPU0:RTARRJO0101(config-bgp-nbr-af)#commit" & @CRLF & _
"Encaminhar ticket quando houver data alinhada para execução de atividade" & @CRLF & _
"Interface com tráfego de 90Mpbs" & @CRLF & _
"Favor, reatribuir ticket quando link tiver "subido"." & @CRLF & _
"Reencaminhar WO quando houver data alinhada para execução" & @CRLF & _
"Devolver WO quando houver data alinhada para atividade. Interfaces em uso." & @CRLF & _
"Reatribuir ticket quando link estiver up." & @CRLF & _
"Devolver WO quando houver data alinhada para atividade. Interfaces em uso." & @CRLF & _
"retornar ticket quando houver alinhamento" & @CRLF & _
"Favor, reatribuir tioket quando houver data alinhada para migração." & @CRLF & _
"Encaminhar WO quando houver data alinhada" & @CRLF & _
"favor prosseguir com a execução." & @CRLF & _
"Quando houver data alinhada para realização dos passos 3 e 4 do plano, favor, reencaminhar WO." & @CRLF & _
"Favor, reencaminhar WO quando houver data alinhada com BACKHAUL/FTTS" & @CRLF & _
"Todas as portas dos Switches estão bloqueadas mas configuradas para outros projetos. Como não tem o ¿default interface¿, não realizado." & @CRLF & _
"Plano não contempla redundância de chassis ¿ enviado e-mail para esclarecimento da eng BBPIP" & @CRLF & _
"Portas em uso." & @CRLF & _
"O next-hop de uma das rotas (ip route 10.208.150.64 255.255.255.252 10.208.192.39 tag 40001 name AFOZ03_IUCS_UP ) não é válida. O IP 10.208.192.39 faz parte da rede O&M SIAE de LDA02 . Além disso, as portas do switch 01 estão em uso" & @CRLF & _
"Encaminhar WO quando houver data alinhada / Circuito entregue" & @CRLF & _
"De acordo com o projeto VSS, a alocação de portas deve acompanhar o par VSS em questão, não sendo possível estender o perímetro L2, ou seja, a vlan 320 deveria estar exclusivamente no SWAVRJO0201 e a vlan 574 exclusivamente no SWAVRJO0202." & @CRLF & _
"Senhores, favor, reencaminhar ticket perto de deta alianhada para integração/ migração de enodebs." & @CRLF & _
"WO desconfigura interface com tráfego e com neighbor BGP UP. Favor rever configuração ou passar maiores informações"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")