// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ism)(insert\s+into\s+casi_tassazione\s+)(\(.+?\))(\s+values\s+)(\(.+?\))(;)").unwrap();
let string = "INSERT INTO CASI_TASSAZIONE (ID_CSTASS, ID_DCHFIS, ESERCIZIO, PROGRESSIVO, ID_PARENT_CSTASS, NO_REINTIMAZIONE, ID_PERGIU, ID_STORGN, TASSAZIONE_UFFICIO, ID_OWNER, ID_WORKER, ID_UNTORG, PRIMO_GIORNO_ESECZ, ULTIMO_GIORNO_ESECZ, DATA_CAMBIO_STORGN, DATA_INS, INS_USERID, DATA_UPD, UPD_USERID) VALUES (100001, 100000, 2009, 0, NULL, 0, 100001, 2, 0, 10000, 10000, @idUnitaOrganizzativa, '2009-01-01', '2009-12-31', '2009-04-24', '2009-04-24 10:09:07.115', 'JUNIT', '2009-04-24 10:09:09.894', 'JUNIT');
INSERT INTO CASI_TASSAZIONE
(ID_CSTASS, ID_DCHFIS, ESERCIZIO, PROGRESSIVO, ID_PARENT_CSTASS, NO_REINTIMAZIONE, ID_PERGIU, ID_STORGN, TASSAZIONE_UFFICIO, ID_OWNER, ID_WORKER, ID_UNTORG, PRIMO_GIORNO_ESECZ, ULTIMO_GIORNO_ESECZ, DATA_CAMBIO_STORGN, DATA_INS, INS_USERID, DATA_UPD, UPD_USERID) VALUES (100001, 100000, 2009, 0, NULL, 0, 100001, 2, 0, 10000, 10000, @idUnitaOrganizzativa, '2009-01-01', '2009-12-31', '2009-04-24', '2009-04-24 10:09:07.115', 'JUNIT', '2009-04-24 10:09:09.894', 'JUNIT'),(ID_CSTASS, ID_DCHFIS, ESERCIZIO, PROGRESSIVO, ID_PARENT_CSTASS, NO_REINTIMAZIONE, ID_PERGIU, ID_STORGN, TASSAZIONE_UFFICIO, ID_OWNER, ID_WORKER, ID_UNTORG, PRIMO_GIORNO_ESECZ, ULTIMO_GIORNO_ESECZ, DATA_CAMBIO_STORGN, DATA_INS, INS_USERID, DATA_UPD, UPD_USERID) VALUES (100001, 100000, 2009, 0, NULL, 0, 100001, 2, 0, 10000, 10000, @idUnitaOrganizzativa, '2009-01-01', '2009-12-31', '2009-04-24', '2009-04-24 10:09:07.115', 'JUNIT', '2009-04-24 10:09:09.894', 'JUNIT');
";
let substitution = "$1$2$3$4$5";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}