# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(insert\s+into\s+casi_tassazione\s+)(\(.+?\))(\s+values\s+)(\(.+?\))(;)"
test_str = ("INSERT INTO CASI_TASSAZIONE (ID_CSTASS, ID_DCHFIS, ESERCIZIO, PROGRESSIVO, ID_PARENT_CSTASS, NO_REINTIMAZIONE, ID_PERGIU, ID_STORGN, TASSAZIONE_UFFICIO, ID_OWNER, ID_WORKER, ID_UNTORG, PRIMO_GIORNO_ESECZ, ULTIMO_GIORNO_ESECZ, DATA_CAMBIO_STORGN, DATA_INS, INS_USERID, DATA_UPD, UPD_USERID) VALUES (100001, 100000, 2009, 0, NULL, 0, 100001, 2, 0, 10000, 10000, @idUnitaOrganizzativa, '2009-01-01', '2009-12-31', '2009-04-24', '2009-04-24 10:09:07.115', 'JUNIT', '2009-04-24 10:09:09.894', 'JUNIT');\n\n"
" INSERT INTO CASI_TASSAZIONE\n"
" (ID_CSTASS, ID_DCHFIS, ESERCIZIO, PROGRESSIVO, ID_PARENT_CSTASS, NO_REINTIMAZIONE, ID_PERGIU, ID_STORGN, TASSAZIONE_UFFICIO, ID_OWNER, ID_WORKER, ID_UNTORG, PRIMO_GIORNO_ESECZ, ULTIMO_GIORNO_ESECZ, DATA_CAMBIO_STORGN, DATA_INS, INS_USERID, DATA_UPD, UPD_USERID) VALUES (100001, 100000, 2009, 0, NULL, 0, 100001, 2, 0, 10000, 10000, @idUnitaOrganizzativa, '2009-01-01', '2009-12-31', '2009-04-24', '2009-04-24 10:09:07.115', 'JUNIT', '2009-04-24 10:09:09.894', 'JUNIT'),(ID_CSTASS, ID_DCHFIS, ESERCIZIO, PROGRESSIVO, ID_PARENT_CSTASS, NO_REINTIMAZIONE, ID_PERGIU, ID_STORGN, TASSAZIONE_UFFICIO, ID_OWNER, ID_WORKER, ID_UNTORG, PRIMO_GIORNO_ESECZ, ULTIMO_GIORNO_ESECZ, DATA_CAMBIO_STORGN, DATA_INS, INS_USERID, DATA_UPD, UPD_USERID) VALUES (100001, 100000, 2009, 0, NULL, 0, 100001, 2, 0, 10000, 10000, @idUnitaOrganizzativa, '2009-01-01', '2009-12-31', '2009-04-24', '2009-04-24 10:09:07.115', 'JUNIT', '2009-04-24 10:09:09.894', 'JUNIT');\n")
subst = "$1$2$3$4$5"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.DOTALL | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.