# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?:G,C,D|A,B,C|E,C,D)|(?:[ABCDEFG](?:#|b)?)(?:\/[ABCDEFG]b)?(?:(?:(?:maj|min|sus|add|aug|dim)(?:\d{0,2}(?:#\d{1,2}|sus\d)?)?)|(?:m\d{0,2}(?:(?:maj|add|#)\d{0,2})?)|(?:-?\d{0,2}(?:\([^)]*\)|#\d{1,2})?))?"
test_str = ("<p>Intro:G,C,D D, A, Em, Eb Ebb G G,C,D</p>\n"
"A,B,C <p><br />\n"
" Verse 1:</p> <p> D A Em <br />\n"
" Yeah I've iced down a few thousand beers in my days<br />\n"
" G <br />\n"
" You put down twice as many<br /> D A Em <br />\n"
"C9 G C#/Db C# Dsus2sus4\n\n"
"Dmaj13#11\n"
"Bmaj13#11\n\n"
"A7(b5,#9)\n\n"
"A7#9\n\n"
"B-5\n\n"
"#sus #maj #min #aug")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.