import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:G,C,D|A,B,C|E,C,D)|(?:[ABCDEFG](?:#|b)?)(?:\\/[ABCDEFG]b)?(?:(?:(?:maj|min|sus|add|aug|dim)(?:\\d{0,2}(?:#\\d{1,2}|sus\\d)?)?)|(?:m\\d{0,2}(?:(?:maj|add|#)\\d{0,2})?)|(?:-?\\d{0,2}(?:\\([^)]*\\)|#\\d{1,2})?))?";
final String string = "<p>Intro:G,C,D D, A, Em, Eb Ebb G G,C,D</p>\n"
+ "A,B,C <p><br />\n"
+ " Verse 1:</p> <p> D A Em <br />\n"
+ " Yeah I've iced down a few thousand beers in my days<br />\n"
+ " G <br />\n"
+ " You put down twice as many<br /> D A Em <br />\n"
+ "C9 G C#/Db C# Dsus2sus4\n\n"
+ "Dmaj13#11\n"
+ "Bmaj13#11\n\n"
+ "A7(b5,#9)\n\n"
+ "A7#9\n\n"
+ "B-5\n\n"
+ "#sus #maj #min #aug";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}