const regex = new RegExp('(?<=\\*[A-Z]{3}:)', 'gm')
const str = `*TOB: hola estamos aquí porque hemos recibido cinco mil euros y tenemos que: decidir (.) qué hacemos con este dinero (.) yo propongo que con este dinero pagamos actividades para que: los estudiantes se conocen y para que aprenden cómo: formar una comunidad un equipo por eso propongo que: pagamos actividades como paintball lastertag o:: m:: a lo mejor una excursión a port aventura para que los estudiantes se pueden conocer y pueden: (.) crecer amis- amistades y tal ¿qué os parece?
*MIN: pue::s ¿de cuán dinero hablamos?
*PPP: (0.9)
*TOB: mh ¿perdón?=`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}